Example Conf


 ADSL Configuration

Router(config)#line vty 0 4
Router(config-line)#pas
Router(config-line)#password wof12345
Router#exit
Router(config)#enable password test1234567890
Router(config)#hostname Ragazzetto
Ragazzetto(config)#interface Vlan1
Ragazzetto(config-if)#ip address 172.31.99.189 255.255.0.0
Ragazzetto(config-if)#wr mem
Ragazzetto#sh conf
Using 803 out of 131072 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ragazzetto
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password test1234567890
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 172.31.99.189 255.255.0.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password wof12345
 login
!
scheduler max-task-time 5000
end
Ragazzetto#
Ragazzetto#
Ragazzetto#
Ragazzetto#conf t
Ragazzetto(config)#interface ATM0
Ragazzetto(config-if)#no shutdown

PPP over ATM o PPPoE

Ragazzetto(config-if)#pvc name_test 8/35
Ragazzetto(config-if-atm-vc)#

Ragazzetto#conf
Ragazzetto(config)#int dialer 1
Ragazzetto(config-if)#ppp authentication pap chap
Ragazzetto(config-if)#ppp pap sent-username ciccio password pluto

Ragazzetto(config-if)#ppp chap hostname ciccio
Ragazzetto(config-if)#ppp chap password pluto

Ragazzetto#sh run
Building configuration...

*Mar  1 00:47:54.888: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1031 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ragazzetto
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password test1234567890
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc ifinet 8/35
  encapsulation aal5snap
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 172.31.99.189 255.255.0.0
!
interface Dialer1
 ip address negotiated
 encapsulation ppp
 ppp authentication pap chap
 ppp chap hostname ciccio
 ppp chap password 0 pluto
 ppp pap sent-username ciccio password 0 pluto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!


Ragazzetto#debug ppp authentication
Ragazzetto(config)#no interface Dialer1


SNAP

Ragazzetto(config)#interface loopback 0
Ragazzetto(config-if)#ip address 81.24.225.113 255.255.255.255
Ragazzetto(config-if)#ip unnumbered loopback 0
Ragazzetto(config)#interface ATM0
Ragazzetto(config-if)#interface ATM0.1 point-to-point
Ragazzetto(config-subif)#pvc ifinet 8/35
Ragazzetto(config-if-atm-vc)#  encapsulation aal5snap
Ragazzetto(config-if-atm-vc)#exit
Ragazzetto(config-subif)#ip unnumbered loopback 0

Ragazzetto#sh run
Building configuration...

*Mar  1 00:57:16.971: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 962 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ragazzetto
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password test1234567890
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface Loopback0
 ip address 81.24.225.113 255.255.255.255
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip unnumbered Loopback0
 pvc ifinet 8/35
  encapsulation aal5snap
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 172.31.99.189 255.255.0.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!


Ragazzetto#sh ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
ATM0                       unassigned      YES unset  down                  down
ATM0.1                     81.24.225.113   YES TFTP   down                  down
FastEthernet0              unassigned      YES unset  up                    down
FastEthernet1              unassigned      YES unset  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
Loopback0                  81.24.225.113   YES manual up                    up
Vlan1                      172.31.99.189   YES manual up                    down

Ragazzetto(config)#ip route 0.0.0.0 0.0.0.0  ATM0.1

Ragazzetto(config)#int atm0.1
Ragazzetto(config-subif)#ip nat outside

Ragazzetto(config-subif)#int vlan1
Ragazzetto(config-if)#ip nat inside
Ragazzetto(config-if)#exit

Ragazzetto(config)#access-list 100 permit ip 172.31.0.0 0.0.255.255 any
Ragazzetto(config)#ip nat inside source list 100 interface loopback 0 overload
Ragazzetto#wr memory

Ragazzetto#sh conf
Using 1183 out of 131072 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Ragazzetto
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password test1234567890
!
no aaa new-model
!

dot11 syslog
ip source-route
!
!
ip cef
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface Loopback0
 ip address 81.24.225.113 255.255.255.255
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip unnumbered Loopback0
 ip nat outside
 ip virtual-reassembly
 pvc ifinet 8/35
  encapsulation aal5snap
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 172.31.99.189 255.255.0.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM0.1
no ip http server
no ip http secure-server
!
ip nat inside source list 100 interface Loopback0 overload
!
access-list 100 permit ip 172.31.0.0 0.0.255.255 any
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 password wof12345
 login
!
scheduler max-task-time 5000
end

Ragazzetto#conf t
Ragazzetto(config)#int loopback 0
Ragazzetto(config-if)#ip address 81.24.225.71 255.255.255.255
Ragazzetto#wr memory

HDSL